Weave Code
Weaver
Helps Laravel developers discover, compare, and choose open-source packages. See popularity, security, maintainers, and scores at a glance to make better decisions.
Feedback
Share your thoughts, report bugs, or suggest improvements.
Subject
Message

Laravel Approvable Laravel Package

victorlap/laravel-approvable

Add approval workflows to any Laravel model with victorlap/laravel-approvable. Submit, approve, or reject records via a simple trait, with configurable approvers, status tracking, and query scopes—ideal for content moderation, publishing pipelines, and multi-step sign-offs.

View on GitHub
Deep Wiki
Context7

Product Decisions This Supports

  • Platform upgrade planning: Release 1.2.0 raises minimum requirements to PHP ^7.2 and Laravel ^5.8|^6.0, so adopting this version forces (or confirms) alignment with Laravel 6 LTS and PHP 7.2+. Use it as a forcing function for modernization roadmaps.
  • Build vs. buy / vendor risk: The release is maintenance-only (dependency constraints), which signals the package is being kept compatible with current frameworks but does not indicate new feature investment. Factor this into vendor risk if you need ongoing enhancements.
  • Feature roadmap: No new product capabilities are introduced in this release. Do not plan feature work around 1.2.0; treat it as a compatibility update only.
  • Upgrade cost estimation: Teams on Laravel 5.7 or earlier, or PHP <7.2, cannot adopt 1.2.0 without upgrading their platform first. This directly affects sprint planning and dependency audits.

When to Consider This Package

  • Consider adoption if your stack is already on Laravel 5.8 or 6.0 and PHP 7.2+, and you need a package whose latest release explicitly supports those versions.
  • Look elsewhere if you are pinned to Laravel 5.7 or below, or PHP <7.2, because 1.2.0 drops compatibility with those versions.
  • Exercise caution if you require active feature development or long-term maintenance guarantees: the release notes show only dependency updates as of August 2019, so validate the package’s current maintenance status before committing.
  • Use as a low-risk maintenance dependency only after confirming no transitive dependency conflicts with your existing Laravel/PHP constraints.

How to Pitch It (Stakeholders)

  • Executives: This is a maintenance release with no new features; its main impact is keeping the package compatible with supported PHP and Laravel versions. It is low-risk if your platform is current, but it may require an upgrade if you are on older versions.
  • Engineering: The release bumps constraints to php@^7.2 and laravel/framework@^5.8|^6.0. Verify composer compatibility, check for transitive dependency conflicts, and plan platform upgrades before adopting 1.2.0 on older stacks. No code or API changes are indicated.
Weaver

How can I help you explore Laravel packages today?

Conversation history is not saved when not logged in.
Prompt
Add packages to context
No packages found.
coleus/frame
thtg88/journalism
filagora/filagora-ai-forums
rlacerda83/query-parser
socialdept/atp-orm
cboxdk/laravel-assistant-client
socialdept/atp-resolver
socialdept/tenant-domains
tautvydasr/blade-class-names
socialdept/color-scales
maherelgamil/controller
coleus/widgets
coleus/table
coleus/users
coleus/music
coleus/health
coleus/calendar
coleus/notes
coleus/support
coleus/settings