srio/api-doc-bundle
srio/api-doc-bundle is a PHP package for generating and serving API documentation from your application's routes and annotations. It simplifies publishing clear endpoint references with minimal configuration, helping teams keep API docs accurate and easy to browse.
Do not install this release. The only information published for 0.0.1 is a maintainer warning: !DO NOT USE THIS RELEASE!. There is no changelog entry, README section, migration note, or tagged issue explaining why — which itself is a signal, not an oversight to work around.
Where to look first, in order:
0.0.1 was tagged in error, yanked, or superseded. A 0.0.1 published with a do-not-use notice is usually one of three things: an accidental CI publish, a placeholder/squatted tag, or a broken first cut the maintainer intends to replace.composer.json on the default branch — check require constraints and whether a replace/abandon flag exists. If the maintainer has abandoned the namespace, stop here.0.0.1 is the only tag and HEAD is far ahead, the release is stale rather than dangerous; if HEAD is the tag, treat the package as unpublished.First use case: none, yet. The correct first action for a Laravel developer today is to verify you are not already pulling it in transitively (composer why <vendor>/<package>), and if you are, constrain it out:
{
"require": {
"vendor/package": "dev-main as 0.0.1"
},
"conflict": {
"vendor/package": "0.0.1"
}
}
Revisit once a 0.0.2+ ships with actual release notes. Until then there is no supported surface to evaluate, so there is no meaningful "leverage" story to write — and inventing one would be worse than saying so.
There are no implementation patterns to recommend, because the release publishes no usable contract. What follows is the pattern for handling a package in this state, which is the real day-to-day concern:
Quarantine, don't integrate. Treat 0.0.1 as a known-bad version rather than an early version. The distinction matters: an early version you can spike on and file bugs against; a version the maintainer says not to use gives you no feedback loop, because any bug you find is already acknowledged.
conflict entry in the consuming application's composer.json rather than relying on memory. This is cheap, survives refactors, and blocks transitive introduction.composer why-not vendor/package 0.0.1 followed by composer show vendor/package to see what actually resolved. Do not assume composer update will fix it — an unbounded ^0.0.1 constraint will happily stay put.Evaluation pattern for when a real release lands. Reserve judgment until you can answer three questions from the release notes alone, without reading source: does it declare a service provider and config publish path, does it document its facade/binding names, and does it state a Laravel version floor. A 0.0.x package that omits all three is not ready for a production Laravel app regardless of the version number.
Integration tip. When you do adopt it, wrap the package behind your own thin interface or a single service class rather than calling it from controllers and jobs. At 0.0.x, the public API is not covered by semver, so the wrapper is what keeps a 0.0.2 breaking rename from becoming a codebase-wide diff.
The version number is not the risk; the absence of explanation is. 0.0.1 is normal for a first publish. A first publish that says do not use and nothing else is abnormal. Do not reason your way past it with "it's probably fine, it's early" — the maintainer knows something you don't, and has chosen not to say what.
Debugging traps specific to this situation:
composer require may still succeed. Composer does not read release notes. A successful install is not evidence of a working package; it only means the tag resolves and the autoload map is valid.php artisan package:discover -v and check bootstrap/cache/packages.php for the entry rather than guessing.0.0.1 was resolved into a composer.lock anywhere in your estate — including CI images and stale feature branches — removing the requirement will not remove the lock entry. composer update vendor/package --with-dependencies or a lock rebuild is required.bootstrap/cache/. After removing it, clear config and route caches; otherwise you can carry a stale reference into the next boot and misattribute the failure.Config quirks. None are documented, so none can be relied upon. Do not infer config keys from the package name or from sibling packages in the same vendor namespace — that is how phantom config files get committed.
Extension points. Unknown and unadvertised. At 0.0.x with no docs, any extension point you find by reading source is unsupported and free to vanish in the next tag. Do not build against it.
What would change this assessment. A 0.0.2+ release with: prose release notes stating what was wrong with 0.0.1, a README with install and usage steps, a stated Laravel version support range, and a tagged changelog. Any one of those alone is insufficient — the do-not-use warning needs an explicit retraction, not just a newer tag sitting on top of it. Absent that, the recommendation stands: constrain it out and re-evaluate on the next real release.
How can I help you explore Laravel packages today?