kaishiyoku/laravel-cli-create-user
A Laravel artisan command package that creates user accounts directly from the CLI. Quickly add new users without opening a browser or tinker, streamlining local development, seeding, and admin setup with a simple interactive terminal prompt.
This assessment is based on release metadata only — the vendor/package name and public API were not supplied with the 4.0.0 notes, so the steps below describe how to onboard and upgrade against the known facts: 4.0.0 requires PHP >= 8.0.2 and Laravel >= 9, and drops support for everything below that.
php -v — must report 8.0.2 or higher (8.0.0 and 8.0.1 are explicitly excluded).composer show laravel/framework — must report 9.x or higher.composer.json for its require block before installing. The php and illuminate/* constraints are the contract that determines whether 4.x is even resolvable in your app.CHANGELOG/UPGRADING file. A major bump that only raises platform floors usually has no API changes, but you need to confirm that rather than assume it.composer require vendor/package:^4.0 --with-dependencies and run your test suite. If that fails on resolution rather than on code, the problem is a transitive constraint, not the package.Pin the major version explicitly. Use "vendor/package": "^4.0" in composer.json rather than * or a bare dev-*. Because 4.0.0 is a version-support drop with (likely) no behavioural change, an unpinned constraint can leave you silently on 3.x while you believe you upgraded.
Keep a CI matrix that mirrors the support floor. Test on PHP 8.0.2 (the true minimum, not 8.1) and Laravel 9, in addition to your production combination. Add composer update --prefer-lowest --prefer-stable as a separate job — this is the only reliable way to prove the new floor actually holds and that you haven't relied on a transitive bump.
Use config.platform.php for reproducible resolution. If your CI or deploy image runs a newer PHP than production, set "config": { "platform": { "php": "8.0.2" } } so Composer resolves against the floor rather than the host binary.
Align illuminate/* constraints with the framework. Laravel packages typically require individual components (illuminate/support, illuminate/contracts). Laravel 9 major-versions those to ^9.0, so a package still declaring ^8.0 will conflict regardless of what laravel/framework says.
If you maintain downstream packages, widen your own constraints ("vendor/package": "^3.0|^4.0") rather than hard-pinning to 4.x. A support-only major release is exactly the case where dual support is cheap — there is no API divergence to branch on.
Staged rollout. Because the change is declarative, upgrading is low-risk on the code side and high-risk on the dependency-graph side. Land it as an isolated dependency commit so a resolution failure is unambiguous and easy to revert.
laravel/framework ^8.0 or php ^7.4 will now form an unsatisfiable set with this package.^3.0 you stay on 3.x indefinitely. Run composer update vendor/package --with-dependencies and confirm with composer show vendor/package afterwards — don't infer the installed version from the constraint string.php8.0 package at various points) have shipped 8.0.0/8.0.1. Check the actual binary, not the package name. The Laravel 9 requirement effectively implies this floor anyway, so the PHP constraint rarely bites in isolation.composer why-not vendor/package 4.0.0 to name the exact blocker, and composer prohibits php 8.0.2 to find packages that refuse the floor. composer diagnose catches repository and platform misconfiguration. composer show --tree shows what pulled in the offending constraint.--ignore-platform-reqs will happily install 4.x on PHP 8.0.1 and produce failures at runtime instead of at install time.illuminate/* ^9.0 accidentally excluding 9.x point releases). Pin ^4.0 so those patches arrive automatically.How can I help you explore Laravel packages today?