gnugat/search-engine-bundle
A Symfony bundle from gnugat that integrates search-engine capabilities into PHP applications, helping developers configure and expose search functionality within Symfony projects. Suitable for adding search-backed features without building the plumbing from scratch.
composer require <vendor>/<package>:^0.3.1. The only changes in v0.3.1 are dependency-range expansions (Symfony 3 and PHPUnit 5), so there is no migration work if you are already on 0.3.0 — but the new ranges are what make the package usable on Laravel 5.2/5.3-era applications whose symfony/* constraints resolved to 3.x.composer.json: confirm the symfony/* and phpunit/phpunit constraints now admit ^3.0 and ^5.0 respectively. That tells you which Laravel versions the release is actually targeting.providers array in config/app.php, and publish any config with php artisan vendor:publish if the package ships one.PHPUnit\Framework\TestCase or the package's own test case base class, expectException() rather than the removed setExpectedException() variants) so you validate the compatibility claim immediately.$this->app->instance(...).RefreshDatabase/DatabaseTransactions as appropriate and assert on the package's public behaviour (HTTP responses, dispatched events, queued jobs) rather than internal classes. This is the pattern that survives future dependency bumps.symfony/*:^3.0 with phpunit/phpunit:^5.0 alongside your existing Symfony 2.7 / PHPUnit 4 jobs. The release is essentially a compatibility statement, so the matrix is the real regression test.^0.3.1 constraint plus the widened transitive ranges can cause composer update to silently move you from Symfony 2.7 to 3.x. Lock the behaviour with explicit constraints in your root composer.json (e.g. "symfony/console": "3.0.*") and commit composer.lock..env, and avoid hard-coding values in the package's config file so deployments and tests can diverge cleanly.PHPUnit_Framework_TestCase was aliased to PHPUnit\Framework\TestCase, and several mocking/prophecy APIs changed. If your suite was written against PHPUnit 4, expect failures that have nothing to do with the package itself; fix the test bootstrap first before blaming the release.composer why-not symfony/console 3.0 (or composer why-not <package> 0.3.1) to see which dependency is holding you back. Laravel 5.1 is pinned to Symfony 2.7 and will not accept the Symfony 3 path; Laravel 5.2/5.3 can.composer show <vendor>/<package> --all to confirm the resolved version, composer diagnose for platform issues, and php artisan tinker to resolve the package's bindings and inspect what the container actually returns.How can I help you explore Laravel packages today?