Weave Code
Weaver
Helps Laravel developers discover, compare, and choose open-source packages. See popularity, security, maintainers, and scores at a glance to make better decisions.
Feedback
Share your thoughts, report bugs, or suggest improvements.
Subject
Message

Http Method Laravel Package

ergebnis/http-method

A small Composer package providing named constants for HTTP request methods, so you can reference GET, POST, PUT, PATCH, DELETE, and others by name instead of magic strings in your PHP code.

View on GitHub
Deep Wiki
Context7
2.9.0

What's Changed

Full Changelog: https://github.com/ergebnis/http-method/compare/2.8.0...2.9.0

2.8.0

What's Changed

Full Changelog: https://github.com/ergebnis/http-method/compare/2.7.0...2.8.0

2.7.0

What's Changed

Full Changelog: https://github.com/ergebnis/http-method/compare/2.6.0...2.7.0

2.6.0

What's Changed

Full Changelog: https://github.com/ergebnis/http-method/compare/2.5.0...2.6.0

2.5.0

What's Changed

New Contributors

Full Changelog: https://github.com/ergebnis/http-method/compare/2.4.0...2.5.0

2.4.0

What's Changed

Full Changelog: https://github.com/ergebnis/http-method/compare/2.3.0...2.4.0

2.3.0

What's Changed

Full Changelog: https://github.com/ergebnis/http-method/compare/2.2.0...2.3.0

2.2.0
  • github-actions(deps): bump actions/checkout from v2.3.3 to v2.3.4 (#275), by @dependabot[bot]
  • github-actions(deps): bump actions/cache from v2.1.2 to v2.1.3 (#277), by @dependabot[bot]
  • github-actions(deps): bump ibiqlik/action-yamllint from v2.0.0 to v3 (#276), by @dependabot[bot]
  • github-actions(deps): bump gr2m/create-or-update-pull-request-action from v1.3.0 to v1.3.1 (#278), by @dependabot[bot]
  • github-actions(deps): bump shivammathur/setup-php from 2.7.0 to 2.8.0 (#280), by @dependabot[bot]
  • github-actions(deps): bump actions/github-script from v3.0.0 to v3.1 (#279), by @dependabot[bot]
  • github-actions(deps): bump actions/stale from v3.0.13 to v3.0.14 (#281), by @dependabot[bot]
  • github-actions(deps): bump shivammathur/setup-php from 2.8.0 to 2.9.0 (#282), by @dependabot[bot]
  • github-actions(deps): bump gr2m/create-or-update-pull-request-action from v1.3.1 to v1.3.3 (#283), by @dependabot[bot]
  • Enhancement: Synchronize with ergebnis/php-library-template (#284), by @localheinz
  • composer(deps-dev): bump phpstan/extension-installer from 1.0.5 to 1.1.0 (#285), by @dependabot[bot]
  • composer(deps-dev): bump ergebnis/php-cs-fixer-config from 2.5.2 to 2.8.0 (#287), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan-deprecation-rules from 0.12.5 to 0.12.6 (#288), by @dependabot[bot]
  • composer(deps-dev): bump ergebnis/test-util from 1.3.0 to 1.4.0 (#289), by @dependabot[bot]
  • composer(deps-dev): bump ergebnis/composer-normalize from 2.10.0 to 2.11.0 (#290), by @dependabot[bot]
  • composer(deps-dev): bump ergebnis/php-cs-fixer-config from 2.8.0 to 2.9.0 (#291), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan-strict-rules from 0.12.5 to 0.12.7 (#292), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan-phpunit from 0.12.16 to 0.12.17 (#293), by @dependabot[bot]
  • composer(deps-dev): bump phpunit/phpunit from 8.5.8 to 8.5.13 (#294), by @dependabot[bot]
  • composer(deps-dev): bump ergebnis/php-cs-fixer-config from 2.9.0 to 2.10.0 (#295), by @dependabot[bot]
  • composer(deps-dev): bump ergebnis/composer-normalize from 2.11.0 to 2.12.1 (#296), by @dependabot[bot]
  • composer(deps-dev): bump ergebnis/composer-normalize from 2.12.1 to 2.13.0 (#297), by @dependabot[bot]
  • Enhancement: Update license year (#299), by @localheinz
  • composer(deps-dev): bump ergebnis/composer-normalize from 2.13.0 to 2.13.2 (#298), by @dependabot[bot]
  • Enhancement: Synchronize with ergebnis/php-library-template (#300), by @localheinz
  • composer(deps-dev): bump phpstan/phpstan from 0.12.64 to 0.12.65 (#301), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.65 to 0.12.66 (#302), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan-strict-rules from 0.12.7 to 0.12.8 (#303), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan-strict-rules from 0.12.8 to 0.12.9 (#304), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.66 to 0.12.67 (#305), by @dependabot[bot]
  • composer(deps-dev): bump phpunit/phpunit from 8.5.13 to 8.5.14 (#306), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.67 to 0.12.68 (#308), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.68 to 0.12.69 (#310), by @dependabot[bot]
  • github-actions(deps): bump actions/stale from v3.0.14 to v3.0.15 (#311), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.69 to 0.12.71 (#315), by @dependabot[bot]
  • github-actions(deps): bump actions/cache from v2.1.3 to v2.1.4 (#316), by @dependabot[bot]
  • github-actions(deps): bump actions/stale from v3.0.15 to v3.0.16 (#317), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.71 to 0.12.73 (#318), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.73 to 0.12.74 (#319), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.74 to 0.12.75 (#320), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.75 to 0.12.76 (#321), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.76 to 0.12.77 (#322), by @dependabot[bot]
  • github-actions(deps): bump actions/stale from v3.0.16 to v3.0.17 (#323), by @dependabot[bot]
  • github-actions(deps): bump stefanzweifel/git-auto-commit-action from v4.8.0 to v4.9.0 (#324), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.77 to 0.12.78 (#325), by @dependabot[bot]
  • github-actions(deps): bump stefanzweifel/git-auto-commit-action from v4.9.0 to v4.9.1 (#326), by @dependabot[bot]
  • github-actions(deps): bump shivammathur/setup-php from 2.9.0 to 2.10.0 (#327), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.78 to 0.12.79 (#328), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.79 to 0.12.80 (#329), by @dependabot[bot]
  • github-actions(deps): bump stefanzweifel/git-auto-commit-action from v4.9.1 to v4.9.2 (#330), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan-phpunit from 0.12.17 to 0.12.18 (#331), by @dependabot[bot]
  • github-actions(deps): bump actions/stale from v3.0.17 to v3.0.18 (#333), by @dependabot[bot]
  • composer(deps-dev): bump ergebnis/composer-normalize from 2.13.2 to 2.13.3 (#332), by @dependabot[bot]
  • composer(deps-dev): bump phpunit/phpunit from 8.5.14 to 8.5.15 (#335), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.80 to 0.12.82 (#336), by @dependabot[bot]
  • Enhancement: Update vimeo/psalm and friends (#337), by @localheinz
  • composer(deps-dev): bump ergebnis/php-cs-fixer-config from 2.10.0 to 2.13.0 (#314), by @dependabot[bot]
  • composer(deps-dev): bump vimeo/psalm from 4.6.4 to 4.7.0 (#338), by @dependabot[bot]
  • composer(deps-dev): bump ergebnis/test-util from 1.4.0 to 1.5.0 (#339), by @dependabot[bot]
  • github-actions(deps): bump stefanzweifel/git-auto-commit-action from v4.9.2 to v4.10.0 (#341), by @dependabot[bot]
  • github-actions(deps): bump actions/cache from v2.1.4 to v2.1.5 (#342), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.82 to 0.12.84 (#343), by @dependabot[bot]
  • composer(deps-dev): bump ergebnis/php-cs-fixer-config from 2.13.0 to 2.13.1 (#344), by @dependabot[bot]
  • github-actions(deps): bump actions/github-script from v3.1 to v4.0.2 (#346), by @dependabot[bot]
  • github-actions(deps): bump shivammathur/setup-php from 2.10.0 to 2.11.0 (#349), by @dependabot[bot]
  • composer(deps-dev): bump ergebnis/php-cs-fixer-config from 2.13.1 to 2.14.0 (#352), by @dependabot[bot]
  • github-actions(deps): bump stefanzweifel/git-auto-commit-action from 4.10.0 to 4.11.0 (#354), by @dependabot[bot]
  • github-actions(deps): bump ibiqlik/action-yamllint from 3 to 3.0.1 (#355), by @dependabot[bot]
  • github-actions(deps): bump actions/stale from 3.0.18 to 3.0.19 (#358), by @dependabot[bot]
  • github-actions(deps): bump actions/cache from 2.1.5 to 2.1.6 (#362), by @dependabot[bot]
  • composer(deps-dev): bump ergebnis/composer-normalize from 2.13.3 to 2.15.0 (#368), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan-phpunit from 0.12.18 to 0.12.20 (#369), by @dependabot[bot]
  • composer(deps-dev): bump vimeo/psalm from 4.7.0 to 4.8.1 (#371), by @dependabot[bot]
  • Enhancement: Restore auto-merge of dependabot pull requests (#387), by @localheinz
  • Enhancement: Add badge for Triage workflow (#388), by @localheinz
  • composer(deps-dev): bump psalm/plugin-phpunit from 0.15.1 to 0.16.1 (#372), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan-strict-rules from 0.12.9 to 0.12.10 (#375), by @dependabot[bot]
  • composer(deps-dev): bump phpunit/phpunit from 8.5.15 to 8.5.19 (#385), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan-phpunit from 0.12.20 to 0.12.22 (#386), by @dependabot[bot]
  • github-actions(deps): bump ibiqlik/action-yamllint from 3.0.1 to 3.0.2 (#374), by @dependabot[bot]
  • github-actions(deps): bump shivammathur/setup-php from 2.11.0 to 2.12.0 (#379), by @dependabot[bot]
  • composer(deps-dev): bump vimeo/psalm from 4.9.2 to 4.9.3 (#389), by @dependabot[bot]
  • github-actions(deps): bump actions/stale from 3.0.19 to 4 (#378), by @dependabot[bot]
  • github-actions(deps): bump ibiqlik/action-yamllint from 3.0.2 to 3.0.3 (#390), by @dependabot[bot]
  • github-actions(deps): bump ibiqlik/action-yamllint from 3.0.3 to 3.0.4 (#392), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.94 to 0.12.95 (#393), by @dependabot[bot]
  • github-actions(deps): bump shivammathur/setup-php from 2.12.0 to 2.13.0 (#394), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.95 to 0.12.96 (#395), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan-strict-rules from 0.12.10 to 0.12.11 (#396), by @dependabot[bot]
  • composer(deps-dev): bump phpunit/phpunit from 8.5.19 to 8.5.20 (#397), by @dependabot[bot]
  • github-actions(deps): bump actions/github-script from 4.0.2 to 4.1 (#391), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.96 to 0.12.97 (#398), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.97 to 0.12.98 (#399), by @dependabot[bot]
  • composer(deps-dev): bump vimeo/psalm from 4.9.3 to 4.10.0 (#400), by @dependabot[bot]
  • github-actions(deps): bump stefanzweifel/git-auto-commit-action from 4.11.0 to 4.12.0 (#401), by @dependabot[bot]
  • github-actions(deps): bump shivammathur/setup-php from 2.13.0 to 2.14.0 (#402), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.98 to 0.12.99 (#403), by @dependabot[bot]
  • github-actions(deps): bump actions/github-script from 4.1 to 5 (#404), by @dependabot[bot]
  • Fix: Adjust usage of octokit (#420), by @localheinz
  • composer(deps-dev): bump phpunit/phpunit from 8.5.20 to 8.5.21 (#405), by @dependabot[bot]
  • Enhancement: Run tests on PHP 8.1 (#421), by @localheinz
  • github-actions(deps): bump ibiqlik/action-yamllint from 3.0.4 to 3.1 (#407), by @dependabot[bot]
  • github-actions(deps): bump actions/cache from 2.1.6 to 2.1.7 (#415), by @dependabot[bot]
  • github-actions(deps): bump shivammathur/setup-php from 2.14.0 to 2.16.0 (#417), by @dependabot[bot]
  • composer(deps-dev): bump vimeo/psalm from 4.10.0 to 4.14.0 (#418), by @dependabot[bot]
  • composer(deps-dev): bump ergebnis/composer-normalize from 2.15.0 to 2.17.0 (#419), by @dependabot[bot]
  • github-actions(deps): bump actions/checkout from 2.3.4 to 2.4.0 (#411), by @dependabot[bot]
  • composer(deps-dev): bump vimeo/psalm from 4.14.0 to 4.15.0 (#422), by @dependabot[bot]
  • composer(deps-dev): bump ergebnis/composer-normalize from 2.17.0 to 2.18.0 (#423), by @dependabot[bot]
  • composer(deps-dev): bump phpunit/phpunit from 8.5.21 to 8.5.22 (#424), by @dependabot[bot]
  • composer(deps-dev): bump vimeo/psalm from 4.15.0 to 4.16.1 (#425), by @dependabot[bot]
  • Fix: Allow composer plugins (#426), by @localheinz
  • Fix: Rename .php_cs to .php-cs-fixer.php (#427), by @localheinz
  • Fix: Drop support for PHP 7.2 (#428), by @localheinz
  • Fix: Drop support for PHP 7.3 (#429), by @localheinz
  • composer(deps-dev): bump phpunit/phpunit from 8.5.22 to 9.5.11 (#431), by @dependabot[bot]
  • Fix: Remove auto-review tests (#432), by @localheinz
  • Fix: Use dashes instead of asterisks for unordered lists (#433), by @localheinz
  • Fix: Reference (#434), by @localheinz
  • Fix: Do not use deprecated --diff-format option (#435), by @localheinz
  • Fix: Rename steps (#436), by @localheinz
  • Fix: Remove empty integration test suite (#437), by @localheinz
  • Enhancement: Use Php73 rule set (#438), by @localheinz
  • Fix: Migrate configuration for phpunit/phpunit (#439), by @localheinz
  • composer(deps-dev): bump ergebnis/php-cs-fixer-config from 2.14.0 to 3.4.0 (#430), by @dependabot[bot]
  • Enhancement: Use Php74 rule set (#440), by @localheinz
  • Fix: Remove phpstan/phpstan (#441), by @localheinz
  • Fix: Do not cache cache directory for vimeo/psalm (#442), by @localheinz
  • Fix: Update CHANGELOG.md (#443), by @localheinz
2.1.0
  • Bump ergebnis/phpstan-rules from 0.14.0 to 0.14.1 (#75), by @dependabot-preview[bot]
  • Bump ergebnis/php-cs-fixer-config from 1.1.0 to 1.1.1 (#76), by @dependabot-preview[bot]
  • Enhancement: Use ergebnis/composer-normalize instead of localheinz/composer-normalize (#77), by @localheinz
  • Bump ergebnis/composer-normalize from 2.0.0 to 2.0.1 (#78), by @dependabot-preview[bot]
  • Bump ergebnis/composer-normalize from 2.0.1 to 2.0.2 (#82), by @dependabot-preview[bot]
  • Bump ergebnis/php-cs-fixer-config from 1.1.1 to 1.1.2 (#79), by @dependabot-preview[bot]
  • Bump ergebnis/test-util from 0.9.0 to 0.9.1 (#80), by @dependabot-preview[bot]
  • Bump ergebnis/phpstan-rules from 0.14.1 to 0.14.2 (#81), by @dependabot-preview[bot]
  • Enhancement: Update phpstan/phpstan and friends (#74), by @localheinz
  • Enhancement: Require phpstan/phpstan-phpunit (#83), by @localheinz
  • Bump ergebnis/composer-normalize from 2.0.2 to 2.1.0 (#85), by @dependabot-preview[bot]
  • Bump phpunit/phpunit from 8.5.0 to 8.5.1 (#84), by @dependabot-preview[bot]
  • Bump ergebnis/composer-normalize from 2.1.0 to 2.1.1 (#86), by @dependabot-preview[bot]
  • Bump ergebnis/composer-normalize from 2.1.1 to 2.1.2 (#87), by @dependabot-preview[bot]
  • Bump ergebnis/composer-normalize from 2.1.2 to 2.2.0 (#88), by @dependabot-preview[bot]
  • Enhancement: Synchronize with ergebnis/php-library-template (#90), by @localheinz
  • Fix: Do not require code coverage reports (#94), by @localheinz
  • Build(deps-dev): Bump phpstan/phpstan-phpunit from 0.12.3 to 0.12.5 (#91), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpstan/phpstan-deprecation-rules from 0.12.0 to 0.12.1 (#93), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpstan/phpstan-strict-rules from 0.12.0 to 0.12.1 (#92), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpstan/phpstan from 0.12.3 to 0.12.4 (#95), by @dependabot-preview[bot]
  • Build(deps-dev): Bump vimeo/psalm from 3.8.1 to 3.8.2 (#96), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpunit/phpunit from 8.5.1 to 8.5.2 (#97), by @dependabot-preview[bot]
  • Enhancement: Synchronize with ergebnis/php-library-template (#98), by @localheinz
  • Build(deps-dev): Bump phpstan/phpstan from 0.12.4 to 0.12.5 (#102), by @dependabot-preview[bot]
  • Build(deps-dev): Bump ergebnis/composer-normalize from 2.2.0 to 2.2.1 (#99), by @dependabot-preview[bot]
  • Build(deps-dev): Bump psalm/plugin-phpunit from 0.8.0 to 0.8.1 (#100), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpstan/phpstan-phpunit from 0.12.5 to 0.12.6 (#101), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpstan/phpstan-deprecation-rules from 0.12.1 to 0.12.2 (#103), by @dependabot-preview[bot]
  • Build(deps-dev): Bump ergebnis/composer-normalize from 2.2.1 to 2.2.2 (#104), by @dependabot-preview[bot]
  • Build(deps-dev): Bump vimeo/psalm from 3.8.2 to 3.8.3 (#105), by @dependabot-preview[bot]
  • Enhancement: Synchronize with ergebnis/php-library-template (#106), by @localheinz
  • Build(deps-dev): Bump ergebnis/php-cs-fixer-config from 1.1.3 to 2.0.0 (#107), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpstan/phpstan from 0.12.5 to 0.12.6 (#108), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpstan/phpstan from 0.12.6 to 0.12.7 (#109), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpstan/phpstan-strict-rules from 0.12.1 to 0.12.2 (#110), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpstan/phpstan from 0.12.7 to 0.12.8 (#111), by @dependabot-preview[bot]
  • Build(deps-dev): Bump ergebnis/phpstan-rules from 0.14.2 to 0.14.3 (#112), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpstan/phpstan from 0.12.8 to 0.12.9 (#113), by @dependabot-preview[bot]
  • Build(deps-dev): Bump vimeo/psalm from 3.8.3 to 3.8.4 (#114), by @dependabot-preview[bot]
  • Build(deps-dev): Bump vimeo/psalm from 3.8.4 to 3.8.5 (#115), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpstan/phpstan from 0.12.9 to 0.12.10 (#116), by @dependabot-preview[bot]
  • Build(deps-dev): Bump psalm/plugin-phpunit from 0.8.1 to 0.9.0 (#117), by @dependabot-preview[bot]
  • Build(deps-dev): Bump ergebnis/composer-normalize from 2.2.2 to 2.2.3 (#118), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpstan/phpstan from 0.12.10 to 0.12.11 (#119), by @dependabot-preview[bot]
  • Build(deps-dev): Bump vimeo/psalm from 3.8.5 to 3.9.0 (#120), by @dependabot-preview[bot]
  • Build(deps-dev): Bump vimeo/psalm from 3.9.0 to 3.9.2 (#121), by @dependabot-preview[bot]
  • Build(deps-dev): Bump vimeo/psalm from 3.9.2 to 3.9.3 (#122), by @dependabot-preview[bot]
  • Build(deps-dev): Bump ergebnis/composer-normalize from 2.2.3 to 2.2.4 (#123), by @dependabot-preview[bot]
  • Build(deps-dev): Bump ergebnis/php-cs-fixer-config from 2.0.0 to 2.1.0 (#124), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpstan/phpstan from 0.12.11 to 0.12.12 (#125), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpstan/phpstan from 0.12.12 to 0.12.14 (#127), by @dependabot-preview[bot]
  • Build(deps-dev): Bump vimeo/psalm from 3.9.3 to 3.9.4 (#128), by @dependabot-preview[bot]
  • Build(deps-dev): Bump vimeo/psalm from 3.9.4 to 3.9.5 (#129), by @dependabot-preview[bot]
  • Build(deps-dev): Bump ergebnis/composer-normalize from 2.2.4 to 2.3.0 (#130), by @dependabot-preview[bot]
  • Build(deps-dev): Bump ergebnis/composer-normalize from 2.3.0 to 2.3.2 (#132), by @dependabot-preview[bot]
  • Build(deps-dev): Bump ergebnis/phpstan-rules from 0.14.3 to 0.14.4 (#133), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpstan/phpstan from 0.12.14 to 0.12.15 (#134), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpstan/phpstan from 0.12.15 to 0.12.16 (#135), by @dependabot-preview[bot]
  • Build(deps-dev): Bump ergebnis/test-util from 0.9.1 to 1.0.0 (#131), by @dependabot-preview[bot]
  • Enhancement: Synchronize with ergebnis/php-library-template (#136), by @localheinz
  • Build(deps-dev): Bump phpstan/phpstan from 0.12.16 to 0.12.17 (#137), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpstan/phpstan from 0.12.17 to 0.12.18 (#138), by @dependabot-preview[bot]
  • Build(deps-dev): Bump vimeo/psalm from 3.9.5 to 3.10.0 (#139), by @dependabot-preview[bot]
  • Build(deps-dev): Bump vimeo/psalm from 3.10.0 to 3.10.1 (#140), by @dependabot-preview[bot]
  • Build(deps-dev): Bump psalm/plugin-phpunit from 0.9.0 to 0.9.1 (#141), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpunit/phpunit from 8.5.2 to 8.5.3 (#142), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpstan/extension-installer from 1.0.3 to 1.0.4 (#143), by @dependabot-preview[bot]
  • Build(deps-dev): Bump psalm/plugin-phpunit from 0.9.1 to 0.9.2 (#144), by @dependabot-preview[bot]
  • Build(deps-dev): Bump psalm/plugin-phpunit from 0.9.2 to 0.10.0 (#145), by @dependabot-preview[bot]
  • Build(deps-dev): Bump ergebnis/php-cs-fixer-config from 2.1.0 to 2.1.1 (#146), by @dependabot-preview[bot]
  • Enhancement: Synchronize with ergebnis/php-library-template (#147), by @localheinz
  • Build(deps-dev): Bump vimeo/psalm from 3.10.1 to 3.11.0 (#148), by @dependabot-preview[bot]
  • Build(deps-dev): Bump vimeo/psalm from 3.11.0 to 3.11.1 (#149), by @dependabot-preview[bot]
  • Fix: Synchronize with ergebnis/php-library-template (#152), by @localheinz
  • Build(deps-dev): Bump phpstan/phpstan-phpunit from 0.12.6 to 0.12.7 (#150), by @dependabot-preview[bot]
  • Build(deps-dev): Bump vimeo/psalm from 3.11.1 to 3.11.2 (#151), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpstan/phpstan-phpunit from 0.12.7 to 0.12.8 (#154), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpstan/phpstan from 0.12.18 to 0.12.19 (#155), by @dependabot-preview[bot]
  • Build(deps-dev): Bump ergebnis/php-cs-fixer-config from 2.1.1 to 2.1.2 (#153), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpunit/phpunit from 8.5.3 to 8.5.4 (#156), by @dependabot-preview[bot]
  • Build(deps-dev): Bump ergebnis/composer-normalize from 2.3.2 to 2.4.0 (#157), by @dependabot-preview[bot]
  • Build(deps-dev): Bump ergebnis/composer-normalize from 2.4.0 to 2.5.0 (#158), by @dependabot-preview[bot]
  • Build(deps-dev): Bump ergebnis/composer-normalize from 2.5.0 to 2.5.1 (#159), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpstan/phpstan from 0.12.19 to 0.12.20 (#160), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpstan/phpstan from 0.12.20 to 0.12.21 (#161), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpstan/phpstan from 0.12.21 to 0.12.22 (#162), by @dependabot-preview[bot]
  • Build(deps-dev): Bump ergebnis/license from 0.1.0 to 1.0.0 (#163), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpstan/phpstan from 0.12.22 to 0.12.23 (#164), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpstan/phpstan from 0.12.23 to 0.12.24 (#165), by @dependabot-preview[bot]
  • Build(deps-dev): Bump ergebnis/phpstan-rules from 0.14.4 to 0.15.0 (#166), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpstan/phpstan from 0.12.24 to 0.12.25 (#167), by @dependabot-preview[bot]
  • Build(deps-dev): Bump vimeo/psalm from 3.11.2 to 3.11.4 (#168), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpstan/phpstan-deprecation-rules from 0.12.2 to 0.12.3 (#169), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpunit/phpunit from 8.5.4 to 8.5.5 (#170), by @dependabot-preview[bot]
  • Build(deps-dev): Bump psalm/plugin-phpunit from 0.10.0 to 0.10.1 (#171), by @dependabot-preview[bot]
  • Build(deps-dev): Bump vimeo/psalm from 3.11.4 to 3.11.5 (#172), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpstan/phpstan-phpunit from 0.12.8 to 0.12.9 (#173), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpstan/phpstan-deprecation-rules from 0.12.3 to 0.12.4 (#174), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpstan/phpstan-phpunit from 0.12.9 to 0.12.10 (#175), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpstan/phpstan-phpunit from 0.12.10 to 0.12.11 (#176), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpstan/phpstan from 0.12.25 to 0.12.26 (#177), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpstan/phpstan from 0.12.26 to 0.12.27 (#178), by @dependabot-preview[bot]
  • Build(deps-dev): Bump phpstan/phpstan from 0.12.27 to 0.12.28 (#179), by @dependabot-preview[bot]
  • Fix: Use main as default branch name (#180), by @localheinz
  • Build(deps-dev): Bump phpstan/phpstan from 0.12.28 to 0.12.29 (#181), by @dependabot-preview[bot]
  • Enhancement: Synchronize with ergebnis/php-library-template (#182), by @localheinz
  • Build(deps-dev): Bump phpunit/phpunit from 8.5.5 to 8.5.6 (#183), by @dependabot[bot]
  • Build(deps-dev): Bump vimeo/psalm from 3.11.5 to 3.11.6 (#186), by @dependabot[bot]
  • Build(deps-dev): Bump phpunit/phpunit from 8.5.6 to 8.5.8 (#189), by @dependabot[bot]
  • Build(deps-dev): Bump phpstan/phpstan from 0.12.29 to 0.12.30 (#188), by @dependabot[bot]
  • Build(deps-dev): Bump vimeo/psalm from 3.11.6 to 3.12.1 (#190), by @dependabot[bot]
  • Build(deps-dev): Bump ergebnis/php-cs-fixer-config from 2.1.2 to 2.2.0 (#191), by @dependabot[bot]
  • Build(deps-dev): Bump phpstan/phpstan from 0.12.30 to 0.12.31 (#192), by @dependabot[bot]
  • Build(deps): Bump actions/create-release from v1 to v1.1.1 (#184), by @dependabot[bot]
  • Build(deps): Bump actions/checkout from v2 to v2.3.0 (#185), by @dependabot[bot]
  • Enhancement: Synchronize with ergebnis/php-library-template (#193), by @localheinz
  • composer(deps-dev): bump ergebnis/php-cs-fixer-config from 2.2.0 to 2.2.1 (#194), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.31 to 0.12.32 (#195), by @dependabot[bot]
  • composer(deps-dev): bump vimeo/psalm from 3.12.1 to 3.12.2 (#196), by @dependabot[bot]
  • composer(deps-dev): bump ergebnis/composer-normalize from 2.5.1 to 2.6.1 (#198), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan-strict-rules from 0.12.2 to 0.12.3 (#199), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.32 to 0.12.33 (#200), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan-phpunit from 0.12.11 to 0.12.12 (#201), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan-deprecation-rules from 0.12.4 to 0.12.5 (#202), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan-phpunit from 0.12.12 to 0.12.13 (#203), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan-strict-rules from 0.12.3 to 0.12.4 (#204), by @dependabot[bot]
  • Fix: Use caret operator (#205), by @localheinz
  • composer(deps-dev): bump phpstan/phpstan-phpunit from 0.12.13 to 0.12.15 (#206), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.33 to 0.12.34 (#207), by @dependabot[bot]
  • composer(deps-dev): bump vimeo/psalm from 3.12.2 to 3.13.1 (#208), by @dependabot[bot]
  • composer(deps-dev): bump ergebnis/phpstan-rules from 0.15.0 to 0.15.1 (#209), by @dependabot[bot]
  • github-actions(deps): bump actions/create-release from v1.1.1 to v1.1.2 (#210), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.34 to 0.12.35 (#211), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan-phpunit from 0.12.15 to 0.12.16 (#213), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.35 to 0.12.36 (#212), by @dependabot[bot]
  • github-actions(deps): bump actions/checkout from v2.3.1 to v2.3.2 (#214), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.36 to 0.12.37 (#215), by @dependabot[bot]
  • github-actions(deps): bump actions/create-release from v1.1.2 to v1.1.3 (#216), by @dependabot[bot]
  • composer(deps-dev): bump ergebnis/composer-normalize from 2.6.1 to 2.7.0 (#217), by @dependabot[bot]
  • composer(deps-dev): bump ergebnis/composer-normalize from 2.7.0 to 2.7.1 (#218), by @dependabot[bot]
  • composer(deps-dev): bump vimeo/psalm from 3.13.1 to 3.14.1 (#219), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.37 to 0.12.38 (#220), by @dependabot[bot]
  • composer(deps-dev): bump vimeo/psalm from 3.14.1 to 3.14.2 (#222), by @dependabot[bot]
  • github-actions(deps): bump actions/github-script from v2 to v3 (#221), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.38 to 0.12.39 (#223), by @dependabot[bot]
  • composer(deps-dev): bump psalm/plugin-phpunit from 0.10.1 to 0.11.0 (#224), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.39 to 0.12.40 (#225), by @dependabot[bot]
  • Enhancement: Synchronize with ergebnis/php-library-template (#226), by @localheinz
  • composer(deps-dev): bump ergebnis/phpstan-rules from 0.15.1 to 0.15.2 (#227), by @dependabot[bot]
  • composer(deps-dev): bump ergebnis/test-util from 1.0.0 to 1.1.0 (#228), by @dependabot[bot]
  • composer(deps-dev): bump ergebnis/license from 1.0.0 to 1.1.0 (#229), by @dependabot[bot]
  • composer(deps-dev): bump ergebnis/php-cs-fixer-config from 2.2.1 to 2.2.2 (#234), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan-strict-rules from 0.12.4 to 0.12.5 (#231), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/extension-installer from 1.0.4 to 1.0.5 (#233), by @dependabot[bot]
  • composer(deps-dev): bump ergebnis/composer-normalize from 2.7.1 to 2.8.1 (#232), by @dependabot[bot]
  • composer(deps-dev): bump psalm/plugin-phpunit from 0.11.0 to 0.12.1 (#230), by @dependabot[bot]
  • composer(deps-dev): bump vimeo/psalm from 3.14.2 to 3.15 (#235), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.40 to 0.12.42 (#236), by @dependabot[bot]
  • github-actions(deps): bump shivammathur/setup-php from 2.4.3 to 2.5.0 (#237), by @dependabot[bot]
  • github-actions(deps): bump actions/stale from v3.0.10 to v3.0.11 (#238), by @dependabot[bot]
  • github-actions(deps): bump actions/create-release from v1.1.3 to v1.1.4 (#239), by @dependabot[bot]
  • composer(deps-dev): bump vimeo/psalm from 3.15 to 3.16 (#240), by @dependabot[bot]
  • github-actions(deps): bump gr2m/create-or-update-pull-request-action from v1.2.10 to v1.3.0 (#241), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.42 to 0.12.43 (#242), by @dependabot[bot]
  • composer(deps-dev): bump ergebnis/composer-normalize from 2.8.1 to 2.8.2 (#243), by @dependabot[bot]
  • github-actions(deps): bump actions/checkout from v2.3.2 to v2.3.3 (#244), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.43 to 0.12.44 (#245), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.44 to 0.12.45 (#246), by @dependabot[bot]
  • composer(deps-dev): bump psalm/plugin-phpunit from 0.12.1 to 0.12.2 (#247), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.45 to 0.12.46 (#248), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.46 to 0.12.47 (#249), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.47 to 0.12.48 (#250), by @dependabot[bot]
  • composer(deps-dev): bump ergebnis/test-util from 1.1.0 to 1.2.0 (#251), by @dependabot[bot]
  • composer(deps-dev): bump ergebnis/test-util from 1.2.0 to 1.3.0 (#252), by @dependabot[bot]
  • github-actions(deps): bump shivammathur/setup-php from 2.5.0 to 2.6.0 (#253), by @dependabot[bot]
  • composer(deps-dev): bump ergebnis/php-cs-fixer-config from 2.2.2 to 2.3.0 (#254), by @dependabot[bot]
  • github-actions(deps): bump actions/stale from v3.0.11 to v3.0.12 (#255), by @dependabot[bot]
  • github-actions(deps): bump actions/cache from v2.1.1 to v2.1.2 (#256), by @dependabot[bot]
  • composer(deps-dev): bump vimeo/psalm from 3.16 to 3.17.1 (#257), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.48 to 0.12.49 (#258), by @dependabot[bot]
  • composer(deps-dev): bump vimeo/psalm from 3.17.1 to 3.17.2 (#259), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.49 to 0.12.50 (#260), by @dependabot[bot]
  • github-actions(deps): bump shivammathur/setup-php from 2.6.0 to 2.7.0 (#261), by @dependabot[bot]
  • composer(deps-dev): bump vimeo/psalm from 3.17.2 to 3.18.0 (#262), by @dependabot[bot]
  • composer(deps-dev): bump vimeo/psalm from 3.18.0 to 3.18.2 (#263), by @dependabot[bot]
  • composer(deps-dev): bump ergebnis/composer-normalize from 2.8.2 to 2.9.0 (#264), by @dependabot[bot]
  • composer(deps-dev): bump ergebnis/php-cs-fixer-config from 2.3.0 to 2.4.0 (#265), by @dependabot[bot]
  • github-actions(deps): bump ibiqlik/action-yamllint from v1.0.0 to v2 (#266), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.50 to 0.12.52 (#267), by @dependabot[bot]
  • composer(deps-dev): bump ergebnis/php-cs-fixer-config from 2.4.0 to 2.5.1 (#268), by @dependabot[bot]
  • composer(deps-dev): bump ergebnis/phpstan-rules from 0.15.2 to 0.15.3 (#269), by @dependabot[bot]
  • composer(deps-dev): bump phpstan/phpstan from 0.12.52 to 0.12.53 (#270), by @dependabot[bot]
  • composer(deps-dev): bump ergebnis/php-cs-fixer-config from 2.5.1 to 2.5.2 (#271), by @dependabot[bot]
  • github-actions(deps): bump actions/stale from v3.0.12 to v3.0.13 (#272), by @dependabot[bot]
  • Enhancement: Synchronize with ergebnis/php-library-template (#273), by @localheinz
  • Enhancement: Add support for PHP 8.0 (#274), by @localheinz
2.0.1
  • Enhancement: Use ergebnis/phpstan-rules instead of localheinz/phpstan-rules (#71), by @localheinz
  • Fix: Use default community health files for @ergebnis (#72), by @localheinz
  • Fix: Remove inappropriate replace configuration (#73), by @localheinz
2.0.0
1.0.0
  • Fix: Remove useless auto-review tests (#1), by @localheinz
  • Fix: Do not require codecov to pass (#2), by @localheinz
  • Fix: Remove non-standard PURGE method (#3), by @localheinz
  • Enhancement: Extract interface for RFC7231 (#5), by @localheinz
  • Fix: No need to run build on PHP 7.2 twice (#6), by @localheinz
  • Enhancement: Extract interface for RFC5789 (#7), by @localheinz
  • Enhancement: Add interface for RFC2068 (#8), by @localheinz
  • Enhancement: Add interface for RFC3253 (#9), by @localheinz
  • Enhancement: Add interface for RFC3648 (#10), by @localheinz
  • Enhancement: Add interface for RFC3744 (#11), by @localheinz
  • Enhancement: Add interface for RFC4437 (#12), by @localheinz
  • Enhancement: Add interface for RFC4791 (#13), by @localheinz
  • Enhancement: Add interface for RFC4918 (#14), by @localheinz
  • Enhancement: Add labels (#20), by @localheinz
  • Enhancement: Add interface for RFC5323 (#15), by @localheinz
  • Enhancement: Add interface for RFC5842 (#16), by @localheinz
  • Enhancement: Add interface for RFC7540 (#17), by @localheinz
  • Enhancement: Add interface for Squid cache request methods (#18), by @localheinz
  • Enhancement: Add interface for Varnish cache request methods (#19), by @localheinz
  • Fix: Case (#21), by @localheinz
  • Enhancement: Wrap extended interfaces (#23), by @localheinz
  • Enhancement: Aggregate HTTP methods related to WebDAV (#22), by @localheinz
  • Bump phpunit/phpunit from 8.2.3 to 8.2.4 (#24), by @dependabot-preview[bot]
  • Enhancement: Update README.md (#25), by @localheinz
  • Enhancement: Update CHANGELOG.md (#26), by @localheinz
Weaver

How can I help you explore Laravel packages today?

Conversation history is not saved when not logged in.
Prompt
Add packages to context
No packages found.
dbravoan/dbcms-admin-theme-dbcms
dbravoan/dbcms-theme-db-cyber
dbravoan/dbcms-blocks-basic
dbravoan/dbcms-module-content-audit
dbravoan/dbcms-module-ai-assistant
paygate-to/paygate-php
padosoft/askmydocs-connector-base
defstudio/supercharged-carbon
bernskioldmedia/laravel-matomo
bernskioldmedia/laravel-harvest
bernskiold/laravel-data-scrubber
bernskiold/laravel-currency-converter
bernskiold/laravel-campaign-monitor
bernskioldmedia/laravel-autotranslate
siberfx/telegram-bot
roy-sandip/laravel-view-extended
gregsphotography/site-builder-core
roy-sandip/laravel-view
anodyne/blade-fluentui-icons
webx-ui/module-catalog-collections