andrey-helldar/laravel-routes-core
Core routing utilities for Laravel, providing reusable classes for defining and organizing application routes. It supports route registration, groups, names, middleware, and controller actions, giving packages and applications a consistent foundation for maintainable route configurations.
composer require andrey-helldar/<package> (5.4.0 is the first line that advertises Laravel 13 support). If you're on Laravel 11/12, pin ^5.4 anyway — there are no breaking changes in this release, so upgrading from 5.3.x is a straight composer update.composer show andrey-helldar/<package> and check the illuminate/* requirements line. This package tracks Laravel majors loosely, so the constraint is the first thing to verify when a new Laravel skeleton goes out.php artisan vendor:publish --provider="Helldar\\...\\ServiceProvider", and exercise it against a single feature branch before touching shared code. Because this release is compatibility-only, the goal of your first run is purely "does it boot and behave identically on my framework version".composer.json with an explicit caret ("andrey-helldar/<package>": "^5.4") rather than *, and use composer why-not andrey-helldar/<package> 5.4.0 to find the dependency blocking you. This package's releases are small and frequent, so a loose constraint buys you silent surprise upgrades.composer.lock will be tiny. Review it in the PR anyway — with packages that support multiple Laravel majors, a resolver change can swap the transitive illuminate/support version underneath you without any source change in your app.composer update andrey-helldar/<package> --with-dependencies). Two green runs (old Laravel, new Laravel) is a cheap and sufficient proof for a compatibility release.^5.3|^5.4 so downstream apps aren't forced to move in lockstep with you.composer.json and src/ before writing code against anything you haven't seen documented — the release notes list only the compatibility addition, so treat the public API as unchanged from 5.3.x.composer update failure with "does not satisfy" is almost always a second package pinning an older illuminate/* range. Use composer depends illuminate/support and composer why-not rather than editing constraints blindly.php artisan --version versus what the lockfile says can diverge in Docker images with cached layers. Verify inside the container before concluding a compatibility bug exists.composer require andrey-helldar/<package>:5.3.*) on a scratch branch. If the behaviour reverts, it's the dependency; if not, it's your Laravel upgrade.^5.4 to avoid an accidental jump across that boundary.How can I help you explore Laravel packages today?